# CVE-2022-0482: Exposure of Private Personal Information to an Unauthorized Actor in alextselegidis/easyappointments

> An attacker can access private personal information of unauthorized actors in the Easy Appointments web application.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-r6cm-wg48-rh2r

## What is CVE-2022-0482?

CVE-2022-0482 is a critical vulnerability in alextselegidis/easyappointments, published on 9 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of Private Personal Information to an Unauthorized Actor in GitHub repository alextselegidis/easyappointments prior to 1.4.3.

Weakness: CWE-863 (Incorrect Authorization), CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-0482?

2 open source packages ship an affected version, including alextselegidis/easyappointments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.4.3 |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.4.3 |

Products: Easyappointments Easyappointments.

## How do I fix CVE-2022-0482?

Upgrade alextselegidis/easyappointments to 1.4.3 or later.

## Is CVE-2022-0482 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0482 exists.

Public exploit code:

- Easy!Appointments < 1.4.3 - Unauthenticated PII (events) disclosure (github_poc): https://github.com/Acceis/exploit-CVE-2022-0482
- A final project for "Network Security" class at NYCU (National Yang Ming Chiao Tung University, Taiwan). Exploiting a CVE in "EasyAppointments" software.  (github_poc): https://github.com/mija-pilkaite/CVE-2022-0482_exploit
- Easy Appointments 1.4.2 - Information Disclosure (exploitdb)
- Easy!Appointments <1.4.3 - Broken Access Control (nuclei): http/cves/2022/CVE-2022-0482.yaml

## Other vulnerabilities in alextselegidis/easyappointments

- [CVE-2023-3287](https://insights.sbomify.com/CVE-2023-3287/): A BOLA vulnerability in POST /admins in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38048](https://insights.sbomify.com/CVE-2023-38048/): A BOLA vulnerability in GET, PUT, DELETE /providers/{providerId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38049](https://insights.sbomify.com/CVE-2023-38049/): A BOLA vulnerability in GET, PUT, DELETE /appointments/{appointmentId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38051](https://insights.sbomify.com/CVE-2023-38051/): A BOLA vulnerability in GET, PUT, DELETE /secretaries/{secretaryId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38052](https://insights.sbomify.com/CVE-2023-38052/): A BOLA vulnerability in GET, PUT, DELETE /admins/{adminId} in EasyAppointments < 1.5.0 (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0482 and fix it if it is affected.

What it is: CVE-2022-0482 is a critical vulnerability in alextselegidis/easyappointments, published on 9 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0482 exists.

Affected packages and fixed versions:
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.4.3
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0482/ (Markdown: https://insights.sbomify.com/CVE-2022-0482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0482
- OSV: https://osv.dev/vulnerability/CVE-2022-0482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0482/
Summaries are generated and may contain mistakes; the official description above is the record.
