# CVE-2022-0502: Cross-site Scripting (XSS) - Stored in livehelperchat/livehelperchat

> Attackers can inject malicious scripts into Live Helper Chat, potentially stealing user sessions or executing code in victim browsers.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-livehelperchat-2022-0502, GHSA-57qf-82hh-2hmc

## What is CVE-2022-0502?

CVE-2022-0502 is a medium-severity cross-site scripting vulnerability in livehelperchat/livehelperchat, published on 6 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Cross-site Scripting (XSS) - Stored in Packagist remdex/livehelperchat prior to 3.93v.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0502?

3 open source packages ship an affected version, including remdex/livehelperchat and livehelperchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remdex/livehelperchat` | Packagist | All versions | 3.93 |
| `remdex/livehelperchat` | Packagist | All versions | 3.93 |
| `livehelperchat` | Bitnami | All versions | 3.92.0 |

Products: Livehelperchat Live Helper Chat.

## How do I fix CVE-2022-0502?

Upgrade remdex/livehelperchat to 3.93 or later.

## Is CVE-2022-0502 being exploited?

There is no known exploitation of CVE-2022-0502 in the wild and no public exploit code.

## Other vulnerabilities in livehelperchat/livehelperchat

- [CVE-2024-27516](https://insights.sbomify.com/CVE-2024-27516/): livehelperchat Server-Side Template Injection (critical 9.8)
- [CVE-2022-0935](https://insights.sbomify.com/CVE-2022-0935/): Host Header injection in password Reset in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1234](https://insights.sbomify.com/CVE-2022-1234/): XSS in livehelperchat in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1191](https://insights.sbomify.com/CVE-2022-1191/): SSRF on index.php/cobrowse/proxycss/ in livehelperchat/livehelperchat (high 8.7)
- [CVE-2022-1213](https://insights.sbomify.com/CVE-2022-1213/): SSRF filter bypass port 80, 433 in livehelperchat/livehelperchat (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0502 and fix it if it is affected.

What it is: CVE-2022-0502 is a medium-severity cross-site scripting vulnerability in livehelperchat/livehelperchat, published on 6 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0502 in the wild and no public exploit code.

Affected packages and fixed versions:
- remdex/livehelperchat (Packagist): affected all versions; fixed in 3.93
- remdex/livehelperchat (Packagist): affected all versions; fixed in 3.93
- livehelperchat (Bitnami): affected all versions; fixed in 3.92.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0502/ (Markdown: https://insights.sbomify.com/CVE-2022-0502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0502
- OSV: https://osv.dev/vulnerability/CVE-2022-0502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0502/
Summaries are generated and may contain mistakes; the official description above is the record.
