{"answers":{"affected":"3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0524 in the wild and no public exploit code.","fix":"Upgrade publify_core to 9.2.7 or later.","what":"CVE-2022-0524 is a medium-severity vulnerability in publify/publify, published on 8 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0524 and fix it if it is affected.\n\nWhat it is: CVE-2022-0524 is a medium-severity vulnerability in publify/publify, published on 8 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- publify_core (RubyGems): affected all versions; fixed in 9.2.7\n- publify_core (RubyGems): affected all versions; fixed in 9.2.7\n- publify (Bitnami): affected all versions; fixed in 9.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0524/ (Markdown: https://insights.sbomify.com/CVE-2022-0524/index.md)","id":"CVE-2022-0524","markdown":"https://insights.sbomify.com/CVE-2022-0524/index.md","name":"CVE-2022-0524","record":{"aliases":["BIT-publify-2022-0524","GHSA-x3rq-r3cm-5vc4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Publify blog platform","requires_auth":"low_privilege","summary":"Attackers can exploit business logic flaws in Publify to bypass intended application workflows or security controls.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"publify","vendor":"publify_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-840","name":null}],"description":"Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Business Logic Errors in publify/publify","id":"CVE-2022-0524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"business_logic","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Out-of-bounds Read in mruby/mruby","id":"CVE-2022-0525"},"packages":[{"ecosystem":"Bitnami","fixed":["9.2.7"],"introduced":["0"],"last_affected":[],"package":"publify","purl":"pkg:bitnami/publify","source":"BIT-publify-2022-0524"},{"ecosystem":"RubyGems","fixed":["9.2.7"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":null,"source":"GHSA-x3rq-r3cm-5vc4"},{"ecosystem":"RubyGems","fixed":["9.2.7"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":"pkg:gem/publify_core","source":"GHSA-x3rq-r3cm-5vc4"}],"prev":{"headline":"Use After Free in radareorg/radare2","id":"CVE-2022-0523"},"products":["publify/publify"],"published":"2022-02-08","related":[{"cvss_score":9.9,"headline":"Authorization Bypass Through User-Controlled Key in publify/publify","id":"CVE-2022-1810","kev_date_added":null,"published":"2022-05-23"},{"cvss_score":9.1,"headline":"Unrestricted Upload of File with Dangerous Type in publify/publify","id":"CVE-2022-1811","kev_date_added":null,"published":"2022-05-23"},{"cvss_score":8.8,"headline":"Leaking password protected articles content due to improper access control in publify/publify","id":"CVE-2022-1553","kev_date_added":null,"published":"2022-05-16"},{"cvss_score":8.4,"headline":"Improper Input Validation in publify/publify","id":"CVE-2023-0299","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":8.1,"headline":"Weak Password Requirements in publify/publify","id":"CVE-2023-0569","kev_date_added":null,"published":"2023-01-29"},{"cvss_score":7.6,"headline":"Integer Overflow or Wraparound in publify/publify","id":"CVE-2022-1812","kev_date_added":null,"published":"2023-01-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["publify"]},"summary":"Attackers can exploit business logic flaws in Publify to bypass intended application workflows or security controls.","url":"https://insights.sbomify.com/CVE-2022-0524/"}