# CVE-2022-0524: Business Logic Errors in publify/publify

> Attackers can exploit business logic flaws in Publify to bypass intended application workflows or security controls.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-publify-2022-0524, GHSA-x3rq-r3cm-5vc4

## What is CVE-2022-0524?

CVE-2022-0524 is a medium-severity vulnerability in publify/publify, published on 8 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.

Weakness: CWE-840

## Which versions are affected by CVE-2022-0524?

3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `publify_core` | RubyGems | All versions | 9.2.7 |
| `publify_core` | RubyGems | All versions | 9.2.7 |
| `publify` | Bitnami | All versions | 9.2.7 |

Products: Publify Project Publify.

## How do I fix CVE-2022-0524?

Upgrade publify_core to 9.2.7 or later.

## Is CVE-2022-0524 being exploited?

There is no known exploitation of CVE-2022-0524 in the wild and no public exploit code.

## Other vulnerabilities in publify/publify

- [CVE-2022-1810](https://insights.sbomify.com/CVE-2022-1810/): Authorization Bypass Through User-Controlled Key in publify/publify (critical 9.9)
- [CVE-2022-1811](https://insights.sbomify.com/CVE-2022-1811/): Unrestricted Upload of File with Dangerous Type in publify/publify (critical 9.1)
- [CVE-2022-1553](https://insights.sbomify.com/CVE-2022-1553/): Leaking password protected articles content due to improper access control in publify/publify (high 8.8)
- [CVE-2023-0299](https://insights.sbomify.com/CVE-2023-0299/): Improper Input Validation in publify/publify (high 8.4)
- [CVE-2023-0569](https://insights.sbomify.com/CVE-2023-0569/): Weak Password Requirements in publify/publify (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0524 and fix it if it is affected.

What it is: CVE-2022-0524 is a medium-severity vulnerability in publify/publify, published on 8 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0524 in the wild and no public exploit code.

Affected packages and fixed versions:
- publify_core (RubyGems): affected all versions; fixed in 9.2.7
- publify_core (RubyGems): affected all versions; fixed in 9.2.7
- publify (Bitnami): affected all versions; fixed in 9.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0524/ (Markdown: https://insights.sbomify.com/CVE-2022-0524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0524
- OSV: https://osv.dev/vulnerability/CVE-2022-0524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0524/
Summaries are generated and may contain mistakes; the official description above is the record.
