# CVE-2022-0528: Server-Side Request Forgery (SSRF) in transloadit/uppy

> An attacker can exploit a Server-Side Request Forgery vulnerability in the Uppy file uploader library to access internal resources.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-q24h-5rq3-63j9

## What is CVE-2022-0528?

CVE-2022-0528 is a medium-severity server-side request forgery vulnerability in transloadit/uppy, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) in GitHub repository transloadit/uppy prior to 3.3.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-0528?

2 open source packages ship an affected version, including @uppy/companion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@uppy/companion` | npm | All versions | 3.3.1 |
| `@uppy/companion` | npm | All versions | 3.3.1 |

Products: Transloadit Uppy.

## How do I fix CVE-2022-0528?

Upgrade @uppy/companion to 3.3.1 or later.

## Is CVE-2022-0528 being exploited?

There is no known exploitation of CVE-2022-0528 in the wild and no public exploit code.

## Other vulnerabilities in transloadit/uppy

- [CVE-2022-0086](https://insights.sbomify.com/CVE-2022-0086/): Server-Side Request Forgery (SSRF) in transloadit/uppy (high 8.2)
- [CVE-2020-8205](https://insights.sbomify.com/CVE-2020-8205/): Server-Side Request Forgery in @uppy/companion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0528 and fix it if it is affected.

What it is: CVE-2022-0528 is a medium-severity server-side request forgery vulnerability in transloadit/uppy, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0528 in the wild and no public exploit code.

Affected packages and fixed versions:
- @uppy/companion (npm): affected all versions; fixed in 3.3.1
- @uppy/companion (npm): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0528/ (Markdown: https://insights.sbomify.com/CVE-2022-0528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0528
- OSV: https://osv.dev/vulnerability/CVE-2022-0528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0528/
Summaries are generated and may contain mistakes; the official description above is the record.
