# CVE-2022-0532: Incorrect Permission Assignment for Critical Resource in CRI-O

> Attackers can escalate privileges by applying host sysctls via pods with host namespaces, requiring specific cluster configurations.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jqmc-79gx-7g8p, GO-2022-0608, RHBA-2022:0793, RHBA-2022:0794

## What is CVE-2022-0532?

CVE-2022-0532 is a medium-severity vulnerability in Redhat Openshift Container Platform, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An incorrect sysctls validation vulnerability was found in CRI-O 1.18 and earlier. The sysctls from the list of "safe" sysctls specified for the cluster will be applied to the host if an attacker is able to create a pod with a hostIPC and hostNetwork kernel namespace.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2022-0532?

3 open source packages ship an affected version, including github.com/cri-o/cri-o. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cri-o/cri-o` | Go | All versions | 1.23.1 |
| `github.com/cri-o/cri-o` | Go | All versions | 1.23.1 |
| `github.com/cri-o/cri-o` | Go | All versions | 1.23.1 |
| `cri-o` | Red Hat:openshift:4.8::el7 | All versions | 0:1.21.5-2.rhaos4.8.gitaf64931.el7 |
| `cri-o-debuginfo` | Red Hat:openshift:4.8::el7 | All versions | 0:1.21.5-2.rhaos4.8.gitaf64931.el7 |
| `cri-o` | Red Hat:openshift:4.8::el8 | All versions | 0:1.21.5-2.rhaos4.8.gitaf64931.el8 |
| `cri-o-debuginfo` | Red Hat:openshift:4.8::el8 | All versions | 0:1.21.5-2.rhaos4.8.gitaf64931.el8 |
| `cri-o-debugsource` | Red Hat:openshift:4.8::el8 | All versions | 0:1.21.5-2.rhaos4.8.gitaf64931.el8 |
| `cri-o` | Red Hat:openshift:4.9::el7 | All versions | 0:1.22.2-2.rhaos4.9.gitb030be8.el7 |
| `cri-o-debuginfo` | Red Hat:openshift:4.9::el7 | All versions | 0:1.22.2-2.rhaos4.9.gitb030be8.el7 |
| `cri-o` | Red Hat:openshift:4.9::el8 | All versions | 0:1.22.2-2.rhaos4.9.gitb030be8.el8 |
| `cri-o-debuginfo` | Red Hat:openshift:4.9::el8 | All versions | 0:1.22.2-2.rhaos4.9.gitb030be8.el8 |
| `cri-o-debugsource` | Red Hat:openshift:4.9::el8 | All versions | 0:1.22.2-2.rhaos4.9.gitb030be8.el8 |

Products: Kubernetes Cri-O, Redhat Openshift Container Platform.

## How do I fix CVE-2022-0532?

Upgrade github.com/cri-o/cri-o to 1.23.1 or later.

## Is CVE-2022-0532 being exploited?

There is no known exploitation of CVE-2022-0532 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2022-0811](https://insights.sbomify.com/CVE-2022-0811/): Code Injection in CRI-O (high 8.8)
- [CVE-2018-1000400](https://insights.sbomify.com/CVE-2018-1000400/): Privilege escalation in n/a (high 8.8)
- [CVE-2024-5154](https://insights.sbomify.com/CVE-2024-5154/): Cri-o: malicious container can create symlink on host (high 8.1)
- [CVE-2022-2995](https://insights.sbomify.com/CVE-2022-2995/): CRI-O incorrect handling of supplementary groups may lead to sensitive information disclosure (high 7.1)
- [CVE-2022-3466](https://insights.sbomify.com/CVE-2022-3466/): Cri-o: security regression of cve-2022-27652 (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0532 and fix it if it is affected.

What it is: CVE-2022-0532 is a medium-severity vulnerability in Redhat Openshift Container Platform, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0532 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.23.1
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.23.1
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.23.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0532/ (Markdown: https://insights.sbomify.com/CVE-2022-0532/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0532
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0532
- OSV: https://osv.dev/vulnerability/CVE-2022-0532

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0532/
Summaries are generated and may contain mistakes; the official description above is the record.
