CVE-2022-0538 DoS vulnerability in bundled XStream library in Jenkins Core

High 7.5 Published Updated

Attackers can cause denial of service in Jenkins by exploiting unconstrained resource usage in custom XStream converters during deserialization.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0538?

CVE-2022-0538 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.

Weakness: CWE-502

Which versions are affected by CVE-2022-0538?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.319.3
org.jenkins-ci.main:jenkins-core MavenAll versions2.319.3
org.jenkins-ci.main:jenkins-core MavenFrom 2.3202.334
org.jenkins-ci.main:jenkins-core MavenFrom 2.3202.334
jenkins BitnamiAll versions2.334.0

Products include Jenkins Jenkins.

How do I fix CVE-2022-0538?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.319.3 or 2.334.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2022-0538 being exploited?

There is no known exploitation of CVE-2022-0538 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as BIT-jenkins-2022-0538, GHSA-34wx-x2w9-vqm3.

Is CVE-2022-0538 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free