{"answers":{"affected":"5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0538 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.319.3 or 2.334.","what":"CVE-2022-0538 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0538 and fix it if it is affected.\n\nWhat it is: CVE-2022-0538 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0538 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.319.3\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.319.3\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.320; fixed in 2.334\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.320; fixed in 2.334\n- jenkins (Bitnami): affected all versions; fixed in 2.334.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0538/ (Markdown: https://insights.sbomify.com/CVE-2022-0538/index.md)","id":"CVE-2022-0538","markdown":"https://insights.sbomify.com/CVE-2022-0538/index.md","name":"CVE-2022-0538","record":{"aliases":["BIT-jenkins-2022-0538","GHSA-34wx-x2w9-vqm3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins automation server","requires_auth":"none","summary":"Attackers can cause denial of service in Jenkins by exploiting unconstrained resource usage in custom XStream converters during deserialization.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"jenkins","vendor":"jenkins"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DoS vulnerability in bundled XStream library in Jenkins Core","id":"CVE-2022-0538","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"jenkins:jenkins","products":["jenkins:jenkins"],"type":"deserialization","year":"2022"},"n_packages":5,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Stored in ptrofimov/beanstalk_console","id":"CVE-2022-0539"},"packages":[{"ecosystem":"Bitnami","fixed":["2.334.0"],"introduced":["0"],"last_affected":[],"package":"jenkins","purl":"pkg:bitnami/jenkins","source":"BIT-jenkins-2022-0538"},{"ecosystem":"Maven","fixed":["2.319.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-34wx-x2w9-vqm3"},{"ecosystem":"Maven","fixed":["2.319.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-34wx-x2w9-vqm3"},{"ecosystem":"Maven","fixed":["2.334"],"introduced":["2.320"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-34wx-x2w9-vqm3"},{"ecosystem":"Maven","fixed":["2.334"],"introduced":["2.320"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-34wx-x2w9-vqm3"}],"prev":{"headline":"MapPress Maps for WordPress \u003c 2.73.13 - Admin+ File Upload to Remote Code Execution","id":"CVE-2022-0537"},"products":["Jenkins"],"published":"2022-02-09","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["Jenkins project"]},"summary":"Attackers can cause denial of service in Jenkins by exploiting unconstrained resource usage in custom XStream converters during deserialization.","url":"https://insights.sbomify.com/CVE-2022-0538/"}