# CVE-2022-0539: Cross-site Scripting (XSS) - Stored in ptrofimov/beanstalk_console

> Stored XSS in Beanstalk Console allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2cjf-w7c4-fhf6

## What is CVE-2022-0539?

CVE-2022-0539 is a medium-severity cross-site scripting vulnerability in ptrofimov/beanstalk_console, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0539?

2 open source packages ship an affected version, including ptrofimov/beanstalk_console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ptrofimov/beanstalk_console` | Packagist | All versions | 1.7.14 |
| `ptrofimov/beanstalk_console` | Packagist | All versions | 1.7.14 |

Products: Beanstalk Console Project Beanstalk Console.

## How do I fix CVE-2022-0539?

Upgrade ptrofimov/beanstalk_console to 1.7.14 or later.

## Is CVE-2022-0539 being exploited?

There is no known exploitation of CVE-2022-0539 in the wild and no public exploit code.

## Other vulnerabilities in ptrofimov/beanstalk_console

- [CVE-2022-0501](https://insights.sbomify.com/CVE-2022-0501/): Cross-site Scripting (XSS) - Reflected in ptrofimov/beanstalk_console (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0539 and fix it if it is affected.

What it is: CVE-2022-0539 is a medium-severity cross-site scripting vulnerability in ptrofimov/beanstalk_console, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0539 in the wild and no public exploit code.

Affected packages and fixed versions:
- ptrofimov/beanstalk_console (Packagist): affected all versions; fixed in 1.7.14
- ptrofimov/beanstalk_console (Packagist): affected all versions; fixed in 1.7.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0539/ (Markdown: https://insights.sbomify.com/CVE-2022-0539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0539
- OSV: https://osv.dev/vulnerability/CVE-2022-0539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0539/
Summaries are generated and may contain mistakes; the official description above is the record.
