{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-0563 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-0563 is a medium-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 21 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0563 and fix it if it is affected.\n\nWhat it is: CVE-2022-0563 is a medium-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 21 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0563 in the wild and no public exploit code.\n\nAffected product: Netapp Ontap Select Deploy Administration Utility. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0563/ (Markdown: https://insights.sbomify.com/CVE-2022-0563/index.md)","id":"CVE-2022-0563","markdown":"https://insights.sbomify.com/CVE-2022-0563/index.md","name":"CVE-2022-0563","record":{"aliases":["ALPINE-CVE-2022-0563","AZL-8841","CLEANSTART-2026-XN90162","DEBIAN-CVE-2022-0563","GHSA-5896-67mw-rv4j","JLSEC-2025-191","ROOT-OS-DEBIAN-12-CVE-2022-0563","openSUSE-SU-2024:11915-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"util-linux utilities","requires_auth":"low_privilege","summary":"An unprivileged user can read root-owned files via the chfn/chsh utilities, potentially leading to privilege escalation.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"util-linux","vendor":"kernel"},{"product":"ontap_select_deploy_administration_utility","vendor":"netapp"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"A flaw was found in the util-linux chfn and chsh utilities when compiled with Readline support. The Readline library uses an \"INPUTRC\" environment variable to get a path to the library config file. When the library cannot parse the specified file, it prints an error message containing data from the file. This flaw allows an unprivileged user to read root-owned files, potentially leading to privilege escalation. This flaw affects util-linux versions prior to 2.37.4.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in util-linux","id":"CVE-2022-0563","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"netapp:ontap_select_deploy_administration_utility","products":["netapp:ontap_select_deploy_administration_utility"],"type":"information_disclosure","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Qlik Sense Enterprise Domain User enumeration","id":"CVE-2022-0564"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.37.4-1.1"],"introduced":["0"],"last_affected":[],"package":"util-linux","purl":"pkg:rpm/opensuse/util-linux\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11915-1"}],"prev":{"headline":"Null dereference in libtiff","id":"CVE-2022-0562"},"products":["util-linux"],"published":"2022-02-21","related":[{"cvss_score":9.8,"headline":"Race condition in n/a","id":"CVE-2015-5224","kev_date_added":null,"published":"2017-08-23"},{"cvss_score":7.8,"headline":"Command injection in n/a","id":"CVE-2018-7738","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2016-2779","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":6.8,"headline":"Util-linux: util-linux: heap use-after-free in libblkid nested partition probing","id":"CVE-2026-13595","kev_date_added":null,"published":"2026-06-29"},{"cvss_score":6.7,"headline":"Command injection in n/a","id":"CVE-2020-21583","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":5.5,"headline":"Integer overflow in n/a","id":"CVE-2021-37600","kev_date_added":null,"published":"2021-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-14","vendors":["n/a"]},"summary":"An unprivileged user can read root-owned files via the chfn/chsh utilities, potentially leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2022-0563/"}