{"answers":{"affected":"5 open source packages ship an affected version, including scrapy. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-0577 in the wild and no public exploit code.","fix":"Upgrade scrapy to a fixed version for your release line: 1.8.2, 2.6.1 or 2.6.0.","what":"CVE-2022-0577 is a high-severity vulnerability in Debian Debian Linux, published on 2 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0577 and fix it if it is affected.\n\nWhat it is: CVE-2022-0577 is a high-severity vulnerability in Debian Debian Linux, published on 2 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0577 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- scrapy (PyPI): affected all versions; fixed in 1.8.2\n- scrapy (PyPI): affected all versions; fixed in 1.8.2\n- scrapy (PyPI): affected all versions; fixed in 2.6.1\n- scrapy (PyPI): affected from 2.0.0; fixed in 2.6.0\n- scrapy (PyPI): affected from 2.0.0; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0577/ (Markdown: https://insights.sbomify.com/CVE-2022-0577/index.md)","id":"CVE-2022-0577","markdown":"https://insights.sbomify.com/CVE-2022-0577/index.md","name":"CVE-2022-0577","record":{"aliases":["DEBIAN-CVE-2022-0577","GHSA-cjvr-mfj7-j4j8","PYSEC-2022-159","UBUNTU-CVE-2022-0577","openSUSE-SU-2024:11889-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web scraping library","requires_auth":"low_privilege","summary":"An attacker can access sensitive information from the Scrapy web scraping library due to improper authorization checks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"scrapy","vendor":"scrapy"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository scrapy/scrapy prior to 2.6.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in scrapy/scrapy","id":"CVE-2022-0577","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"information_disclosure","year":"2022"},"n_packages":5,"n_references":3,"next":{"headline":"Code Injection in publify/publify","id":"CVE-2022-0578"},"packages":[{"ecosystem":"PyPI","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"scrapy","purl":null,"source":"GHSA-cjvr-mfj7-j4j8"},{"ecosystem":"PyPI","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"scrapy","purl":"pkg:pypi/scrapy","source":"GHSA-cjvr-mfj7-j4j8"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"scrapy","purl":"pkg:pypi/scrapy","source":"PYSEC-2022-159"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["2.0.0"],"last_affected":[],"package":"scrapy","purl":null,"source":"GHSA-cjvr-mfj7-j4j8"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["2.0.0"],"last_affected":[],"package":"scrapy","purl":"pkg:pypi/scrapy","source":"GHSA-cjvr-mfj7-j4j8"}],"prev":{"headline":"Cross-site Scripting (XSS) - Generic in librenms/librenms","id":"CVE-2022-0576"},"products":["scrapy/scrapy"],"published":"2022-03-02","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["scrapy"]},"summary":"An attacker can access sensitive information from the Scrapy web scraping library due to improper authorization checks.","url":"https://insights.sbomify.com/CVE-2022-0577/"}