{"answers":{"affected":"2 open source packages ship an affected version, including tastyigniter/tastyigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0602 in the wild and no public exploit code.","fix":"Upgrade tastyigniter/tastyigniter to 3.3.0 or later.","what":"CVE-2022-0602 is a high-severity cross-site scripting vulnerability in tastyigniter/tastyigniter, published on 5 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0602 and fix it if it is affected.\n\nWhat it is: CVE-2022-0602 is a high-severity cross-site scripting vulnerability in tastyigniter/tastyigniter, published on 5 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0602 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tastyigniter/tastyigniter (Packagist): affected all versions; fixed in 3.3.0\n- tastyigniter/tastyigniter (Packagist): affected all versions; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0602/ (Markdown: https://insights.sbomify.com/CVE-2022-0602/index.md)","id":"CVE-2022-0602","markdown":"https://insights.sbomify.com/CVE-2022-0602/index.md","name":"CVE-2022-0602","record":{"aliases":["GHSA-cjw5-f2x5-r4q5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"TastyIgniter web app","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in TastyIgniter, potentially leading to session hijacking or data theft.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"tastyigniter","vendor":"tastyigniter"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter","id":"CVE-2022-0602","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Use after free in Chrome","id":"CVE-2022-0603"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"tastyigniter/tastyigniter","purl":null,"source":"GHSA-cjw5-f2x5-r4q5"},{"ecosystem":"Packagist","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"tastyigniter/tastyigniter","purl":"pkg:composer/tastyigniter/tastyigniter","source":"GHSA-cjw5-f2x5-r4q5"}],"prev":{"headline":"Countdown \u0026 Clock \u003c 2.2.9 - Reflected Cross-Site Scripting","id":"CVE-2022-0601"},"products":["tastyigniter/tastyigniter"],"published":"2022-04-05","related":[{"cvss_score":8.8,"headline":"TastyIgniter vulnerable to Cross-Site Scripting","id":"CVE-2025-61417","kev_date_added":null,"published":"2025-10-20"},{"cvss_score":8.1,"headline":"TastyIgniter Has an Incorrect Access Control Vulnerability via `invoice()` Function","id":"CVE-2024-44313","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":6.5,"headline":"TastyIgniter Has an Incorrect Access Control Vulnerability","id":"CVE-2024-44314","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2022-38256","kev_date_added":null,"published":"2022-09-08"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2022-23378","kev_date_added":null,"published":"2022-02-09"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2021-38699","kev_date_added":null,"published":"2021-08-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["tastyigniter"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in TastyIgniter, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2022-0602/"}