# CVE-2022-0613: Authorization Bypass Through User-Controlled Key in medialize/uri.js


- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-gcv8-gh4r-25x6, RHBA-2022:1352, RHBA-2022:1386, UBUNTU-CVE-2022-0613

## What is CVE-2022-0613?

CVE-2022-0613 is a medium-severity vulnerability in Fedoraproject Fedora, published on 16 Feb 2022. 

### Official description

Authorization Bypass Through User-Controlled Key in NPM urijs prior to 1.19.8.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-0613?

2 open source packages ship an affected version, including urijs. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urijs` | npm | All versions | 1.19.8 |
| `urijs` | npm | All versions | 1.19.8 |
| `aspnetcore-runtime-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `aspnetcore-targeting-pack-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-apphost-pack-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-apphost-pack-3.1-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-hostfxr-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-hostfxr-3.1-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-runtime-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-runtime-3.1-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-sdk-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.418-1.el8_5 |
| `dotnet-sdk-3.1-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.418-1.el8_5 |
| `dotnet-targeting-pack-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-templates-3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.418-1.el8_5 |
| `dotnet3.1` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.418-1.el8_5 |
| `dotnet3.1-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.418-1.el8_5 |
| `dotnet3.1-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.1.418-1.el8_5 |
| `dotnet-apphost-pack-3.1-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-hostfxr-3.1-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-runtime-3.1-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.24-1.el8_5 |
| `dotnet-sdk-3.1-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.418-1.el8_5 |
| `dotnet-sdk-3.1-source-built-artifacts` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.418-1.el8_5 |
| `dotnet3.1-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.418-1.el8_5 |
| `dotnet3.1-debugsource` | Red Hat:enterprise_linux:8::crb | All versions | 0:3.1.418-1.el8_5 |
| `rh-dotnet31-aspnetcore-runtime-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-aspnetcore-targeting-pack-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-dotnet` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.418-1.el7_9 |
| `rh-dotnet31-dotnet-apphost-pack-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-dotnet-debuginfo` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.418-1.el7_9 |
| `rh-dotnet31-dotnet-host` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-dotnet-hostfxr-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-dotnet-runtime-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-dotnet-sdk-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.418-1.el7_9 |
| `rh-dotnet31-dotnet-sdk-3.1-source-built-artifacts` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.418-1.el7_9 |
| `rh-dotnet31-dotnet-targeting-pack-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.24-1.el7_9 |
| `rh-dotnet31-dotnet-templates-3.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.418-1.el7_9 |
| `rh-dotnet31-netstandard-targeting-pack-2.1` | Red Hat:rhel_dotnet:3.1::el7 | All versions | 0:3.1.418-1.el7_9 |

Products: Fedoraproject Fedora, Uri.js Project Uri.js.

## How do I fix CVE-2022-0613?

Upgrade urijs to 1.19.8 or later.

## Is CVE-2022-0613 being exploited?

There is no known exploitation of CVE-2022-0613 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0613 and fix it if it is affected.

What it is: CVE-2022-0613 is a medium-severity vulnerability in Fedoraproject Fedora, published on 16 Feb 2022. 
Exploitation: There is no known exploitation of CVE-2022-0613 in the wild and no public exploit code.

Affected packages and fixed versions:
- urijs (npm): affected all versions; fixed in 1.19.8
- urijs (npm): affected all versions; fixed in 1.19.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0613/ (Markdown: https://insights.sbomify.com/CVE-2022-0613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0613
- OSV: https://osv.dev/vulnerability/CVE-2022-0613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0613/
Summaries are generated and may contain mistakes; the official description above is the record.
