# CVE-2022-0624: Authorization Bypass Through User-Controlled Key in ionicabizau/parse-path

> An attacker can bypass authorization controls by manipulating user-controlled keys in the parse-path library, potentially accessing restricted resources.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2022
- **Updated:** 2 Aug 2024
- **Also known as:** CLSA-2026-1790604895, CLSA-2026-1790707419, GHSA-3j8f-xvm3-ffx4

## What is CVE-2022-0624?

CVE-2022-0624 is a medium-severity authentication bypass vulnerability in ionicabizau/parse-path, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authorization Bypass Through User-Controlled Key in GitHub repository ionicabizau/parse-path prior to 5.0.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-0624?

2 open source packages ship an affected version, including parse-path. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-path` | npm | All versions | 5.0.0 |
| `parse-path` | npm | All versions | 5.0.0 |

Products: Parse-Path Project Parse-Path.

## How do I fix CVE-2022-0624?

Upgrade parse-path to 5.0.0 or later.

## Is CVE-2022-0624 being exploited?

There is no known exploitation of CVE-2022-0624 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0624 and fix it if it is affected.

What it is: CVE-2022-0624 is a medium-severity authentication bypass vulnerability in ionicabizau/parse-path, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0624 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-path (npm): affected all versions; fixed in 5.0.0
- parse-path (npm): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0624/ (Markdown: https://insights.sbomify.com/CVE-2022-0624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0624
- OSV: https://osv.dev/vulnerability/CVE-2022-0624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0624/
Summaries are generated and may contain mistakes; the official description above is the record.
