{"answers":{"affected":"3 open source packages ship an affected version, including pollbot. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0637 in the wild and no public exploit code.","fix":"Upgrade pollbot to 1.4.6 or later.","what":"CVE-2022-0637 is a medium-severity vulnerability in mozilla/pollbot, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0637 and fix it if it is affected.\n\nWhat it is: CVE-2022-0637 is a medium-severity vulnerability in mozilla/pollbot, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0637 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pollbot (PyPI): affected all versions; fixed in 1.4.6\n- pollbot (PyPI): affected all versions; fixed in 1.4.6\n- pollbot (PyPI): affected all versions; fixed in 1.4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0637/ (Markdown: https://insights.sbomify.com/CVE-2022-0637/index.md)","id":"CVE-2022-0637","markdown":"https://insights.sbomify.com/CVE-2022-0637/index.md","name":"CVE-2022-0637","record":{"aliases":["GHSA-vg27-hr3v-3cqv","PYSEC-2026-738"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mozilla Pollbot","requires_auth":"none","summary":"Attackers can redirect users to malicious sites via the Mozilla Pollbot service, potentially enabling phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mozilla","cpe":[{"product":"pollbot","vendor":"mozilla"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"open redirect in pollbot (pollbot.services.mozilla.com) in versions before 1.4.6","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"open redirect in pollbot","id":"CVE-2022-0637","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"open_redirect","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"Cross-Site Request Forgery (CSRF) in microweber/microweber","id":"CVE-2022-0638"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.6"],"introduced":["0"],"last_affected":[],"package":"pollbot","purl":null,"source":"GHSA-vg27-hr3v-3cqv"},{"ecosystem":"PyPI","fixed":["1.4.6"],"introduced":["0"],"last_affected":[],"package":"pollbot","purl":"pkg:pypi/pollbot","source":"GHSA-vg27-hr3v-3cqv"},{"ecosystem":"PyPI","fixed":["1.4.6"],"introduced":["0"],"last_affected":[],"package":"pollbot","purl":"pkg:pypi/pollbot","source":"PYSEC-2026-738"}],"prev":{"headline":"Denial of service in Thin Installer","id":"CVE-2022-0636"},"products":["mozilla/pollbot"],"published":"2023-02-16","related":[{"cvss_score":7.4,"headline":"Open redirect in pollbot","id":"CVE-2021-21354","kev_date_added":null,"published":"2021-03-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["n/a"]},"summary":"Attackers can redirect users to malicious sites via the Mozilla Pollbot service, potentially enabling phishing attacks.","url":"https://insights.sbomify.com/CVE-2022-0637/"}