# CVE-2022-0637: open redirect in pollbot

> Attackers can redirect users to malicious sites via the Mozilla Pollbot service, potentially enabling phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-vg27-hr3v-3cqv, PYSEC-2026-738

## What is CVE-2022-0637?

CVE-2022-0637 is a medium-severity vulnerability in mozilla/pollbot, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

open redirect in pollbot (pollbot.services.mozilla.com) in versions before 1.4.6

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-0637?

3 open source packages ship an affected version, including pollbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pollbot` | PyPI | All versions | 1.4.6 |
| `pollbot` | PyPI | All versions | 1.4.6 |
| `pollbot` | PyPI | All versions | 1.4.6 |

Products: Mozilla Pollbot.

## How do I fix CVE-2022-0637?

Upgrade pollbot to 1.4.6 or later.

## Is CVE-2022-0637 being exploited?

There is no known exploitation of CVE-2022-0637 in the wild and no public exploit code.

## Other vulnerabilities in mozilla/pollbot

- [CVE-2021-21354](https://insights.sbomify.com/CVE-2021-21354/): Open redirect in pollbot (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0637 and fix it if it is affected.

What it is: CVE-2022-0637 is a medium-severity vulnerability in mozilla/pollbot, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0637 in the wild and no public exploit code.

Affected packages and fixed versions:
- pollbot (PyPI): affected all versions; fixed in 1.4.6
- pollbot (PyPI): affected all versions; fixed in 1.4.6
- pollbot (PyPI): affected all versions; fixed in 1.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0637/ (Markdown: https://insights.sbomify.com/CVE-2022-0637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0637
- OSV: https://osv.dev/vulnerability/CVE-2022-0637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0637/
Summaries are generated and may contain mistakes; the official description above is the record.
