{"answers":{"affected":"2 open source packages ship an affected version, including org.eclipse.lemminx:lemminx-parent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0672 in the wild and no public exploit code.","fix":"Upgrade org.eclipse.lemminx:lemminx-parent to 0.19.0 or later.","what":"CVE-2022-0672 is a medium-severity vulnerability in LemMinX, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0672 and fix it if it is affected.\n\nWhat it is: CVE-2022-0672 is a medium-severity vulnerability in LemMinX, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.eclipse.lemminx:lemminx-parent (Maven): affected all versions; fixed in 0.19.0\n- org.eclipse.lemminx:lemminx-parent (Maven): affected all versions; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0672/ (Markdown: https://insights.sbomify.com/CVE-2022-0672/index.md)","id":"CVE-2022-0672","markdown":"https://insights.sbomify.com/CVE-2022-0672/index.md","name":"CVE-2022-0672","record":{"aliases":["GHSA-hrxv-694f-22g3"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"LemMinX language server","requires_auth":"low_privilege","summary":"An insecure redirect in LemMinX allows local attackers to access sensitive information when the tool runs under a privileged user.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"lemminx","vendor":"eclipse"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A flaw was found in LemMinX in versions prior to 0.19.0. Insecure redirect could allow unauthorized access to sensitive information locally if LemMinX is run under a privileged user.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in LemMinX","id":"CVE-2022-0672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Path Traversal in LemMinX","id":"CVE-2022-0673"},"packages":[{"ecosystem":"Maven","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"org.eclipse.lemminx:lemminx-parent","purl":null,"source":"GHSA-hrxv-694f-22g3"},{"ecosystem":"Maven","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"org.eclipse.lemminx:lemminx-parent","purl":"pkg:maven/org.eclipse.lemminx/lemminx-parent","source":"GHSA-hrxv-694f-22g3"}],"prev":{"headline":"Server-Side Request Forgery and Uncontrolled Resource Consumption in LemMinX","id":"CVE-2022-0671"},"products":["LemMinX"],"published":"2022-02-18","related":[{"cvss_score":6.5,"headline":"Path Traversal in LemMinX","id":"CVE-2022-0673","kev_date_added":null,"published":"2022-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An insecure redirect in LemMinX allows local attackers to access sensitive information when the tool runs under a privileged user.","url":"https://insights.sbomify.com/CVE-2022-0672/"}