# CVE-2022-0672: Exposure of Sensitive Information to an Unauthorized Actor in LemMinX

> An insecure redirect in LemMinX allows local attackers to access sensitive information when the tool runs under a privileged user.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hrxv-694f-22g3

## What is CVE-2022-0672?

CVE-2022-0672 is a medium-severity vulnerability in LemMinX, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in LemMinX in versions prior to 0.19.0. Insecure redirect could allow unauthorized access to sensitive information locally if LemMinX is run under a privileged user.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-0672?

2 open source packages ship an affected version, including org.eclipse.lemminx:lemminx-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.lemminx:lemminx-parent` | Maven | All versions | 0.19.0 |
| `org.eclipse.lemminx:lemminx-parent` | Maven | All versions | 0.19.0 |

Products: Eclipse Lemminx.

## How do I fix CVE-2022-0672?

Upgrade org.eclipse.lemminx:lemminx-parent to 0.19.0 or later.

## Is CVE-2022-0672 being exploited?

There is no known exploitation of CVE-2022-0672 in the wild and no public exploit code.

## Other vulnerabilities in LemMinX

- [CVE-2022-0673](https://insights.sbomify.com/CVE-2022-0673/): Path Traversal in LemMinX (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0672 and fix it if it is affected.

What it is: CVE-2022-0672 is a medium-severity vulnerability in LemMinX, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0672 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.lemminx:lemminx-parent (Maven): affected all versions; fixed in 0.19.0
- org.eclipse.lemminx:lemminx-parent (Maven): affected all versions; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0672/ (Markdown: https://insights.sbomify.com/CVE-2022-0672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0672
- OSV: https://osv.dev/vulnerability/CVE-2022-0672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0672/
Summaries are generated and may contain mistakes; the official description above is the record.
