{"answers":{"affected":"3 open source packages ship an affected version, including archivy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0697 in the wild and no public exploit code.","fix":"Upgrade archivy to a fixed version for your release line: 1.7.0 or 1.7.1.","what":"CVE-2022-0697 is a low-severity vulnerability in archivy/archivy, published on 6 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0697 and fix it if it is affected.\n\nWhat it is: CVE-2022-0697 is a low-severity vulnerability in archivy/archivy, published on 6 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- archivy (PyPI): affected all versions; fixed in 1.7.0\n- archivy (PyPI): affected all versions; fixed in 1.7.1\n- archivy (PyPI): affected all versions; fixed in 1.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0697/ (Markdown: https://insights.sbomify.com/CVE-2022-0697/index.md)","id":"CVE-2022-0697","markdown":"https://insights.sbomify.com/CVE-2022-0697/index.md","name":"CVE-2022-0697","record":{"aliases":["GHSA-28mg-98xm-q493","PYSEC-2022-161"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Archivy web application","requires_auth":"none","summary":"An open redirect vulnerability in Archivy allows attackers to redirect users to malicious sites, potentially facilitating phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"archivy","vendor":"archivy_project"}],"cvss":{"score":3.4,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Open Redirect in GitHub repository archivy/archivy prior to 1.7.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect in archivy/archivy","id":"CVE-2022-0697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"open_redirect","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Microweber vulnerable to cross-site scripting (XSS)","id":"CVE-2022-0698"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"archivy","purl":"pkg:pypi/archivy","source":"PYSEC-2022-161"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"archivy","purl":null,"source":"GHSA-28mg-98xm-q493"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"archivy","purl":"pkg:pypi/archivy","source":"GHSA-28mg-98xm-q493"}],"prev":{"headline":"NULL Pointer Dereference in vim/vim","id":"CVE-2022-0696"},"products":["archivy/archivy"],"published":"2022-03-06","related":[{"cvss_score":4.3,"headline":"Cross-Site Request Forgery (CSRF) in archivy/archivy","id":"CVE-2021-4162","kev_date_added":null,"published":"2021-12-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["archivy"]},"summary":"An open redirect vulnerability in Archivy allows attackers to redirect users to malicious sites, potentially facilitating phishing attacks.","url":"https://insights.sbomify.com/CVE-2022-0697/"}