# CVE-2022-0718: python-oslo-utils has improper password parsing

> Improper password masking in debug logs exposes plaintext password segments, requiring debug mode to be enabled.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2022
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-0718, DLA-3106-1, DLA-3870-1, GHSA-wmqq-r32m-87c5, MGASA-2022-0189, PYSEC-2022-258, RHSA-2022:0993, RHSA-2022:8873, SUSE-SU-2025:02448-1, UBUNTU-CVE-2022-0718, USN-5369-1

## What is CVE-2022-0718?

CVE-2022-0718 is a medium-severity vulnerability in Debian Debian Linux, published on 29 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in python-oslo-utils. Due to improper parsing, passwords with a double quote ( " ) in them cause incorrect masking in debug logs, causing any part of the password after the double quote to be plaintext.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2022-0718?

3 open source packages ship an affected version, including oslo-utils. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oslo-utils` | PyPI | All versions | 4.10.1 |
| `oslo-utils` | PyPI | All versions | 4.10.1 |
| `oslo-utils` | PyPI | All versions | 4.10.1 |
| `python-oslo-utils` | Red Hat:openstack:16.1::el8 | All versions | 0:3.41.6-1.20220426095230.f4deaad.el8ost |
| `python-oslo-utils-lang` | Red Hat:openstack:16.1::el8 | All versions | 0:3.41.6-1.20220426095230.f4deaad.el8ost |
| `python3-oslo-utils` | Red Hat:openstack:16.1::el8 | All versions | 0:3.41.6-1.20220426095230.f4deaad.el8ost |
| `python-oslo-utils` | Red Hat:openstack:16.2::el8 | All versions | 0:3.41.6-2.20220111011750.el8ost |
| `python-oslo-utils-lang` | Red Hat:openstack:16.2::el8 | All versions | 0:3.41.6-2.20220111011750.el8ost |
| `python3-oslo-utils` | Red Hat:openstack:16.2::el8 | All versions | 0:3.41.6-2.20220111011750.el8ost |
| `python-oslo.utils` | SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 4.1.1-150200.8.7.1 |
| `python-oslo.utils` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 4.1.1-150200.8.7.1 |
| `python-oslo.utils` | SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 4.1.1-150200.8.7.1 |
| `python-oslo.utils` | SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 4.1.1-150200.8.7.1 |
| `python-oslo.utils` | SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 4.1.1-150200.8.7.1 |
| `python-oslo.utils` | openSUSE:Leap 15.6 | All versions | 4.1.1-150200.8.7.1 |

Products: Debian Debian Linux, Openstack Oslo.utils, Redhat Openshift Container Platform, Redhat Openstack Platform.

## How do I fix CVE-2022-0718?

Upgrade oslo-utils to 4.10.1 or later.

## Is CVE-2022-0718 being exploited?

There is no known exploitation of CVE-2022-0718 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0718 and fix it if it is affected.

What it is: CVE-2022-0718 is a medium-severity vulnerability in Debian Debian Linux, published on 29 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0718 in the wild and no public exploit code.

Affected packages and fixed versions:
- oslo-utils (PyPI): affected all versions; fixed in 4.10.1
- oslo-utils (PyPI): affected all versions; fixed in 4.10.1
- oslo-utils (PyPI): affected all versions; fixed in 4.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0718/ (Markdown: https://insights.sbomify.com/CVE-2022-0718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0718
- OSV: https://osv.dev/vulnerability/CVE-2022-0718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0718/
Summaries are generated and may contain mistakes; the official description above is the record.
