# CVE-2022-0721: Insertion of Sensitive Information Into Debugging Code in microweber/microweber

> Attackers can access sensitive information exposed in debugging code within the Microweber CMS application.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-mjvc-j6rv-9xj8

## What is CVE-2022-0721?

CVE-2022-0721 is a high-severity vulnerability in Microweber Microweber, published on 23 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insertion of Sensitive Information Into Debugging Code in GitHub repository microweber/microweber prior to 1.3.

Weakness: CWE-215 (Insertion of Sensitive Information Into Debugging Code)

## Which versions are affected by CVE-2022-0721?

2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `microweber/microweber` | Packagist | All versions | 1.3 |
| `microweber/microweber` | Packagist | All versions | 1.3 |

Products: Microweber Microweber.

## How do I fix CVE-2022-0721?

Upgrade microweber/microweber to 1.3 or later.

## Is CVE-2022-0721 being exploited?

There is no known exploitation of CVE-2022-0721 in the wild and no public exploit code.

## Other vulnerabilities in Microweber Microweber

- [CVE-2022-0558](https://insights.sbomify.com/CVE-2022-0558/): Cross-site Scripting (XSS) - Stored in microweber/microweber (critical 9.8)
- [CVE-2020-23138](https://insights.sbomify.com/CVE-2020-23138/): File upload in n/a (critical 9.8)
- [CVE-2022-0688](https://insights.sbomify.com/CVE-2022-0688/): Business Logic Errors in microweber/microweber (critical 9.4)
- [CVE-2022-0660](https://insights.sbomify.com/CVE-2022-0660/): Generation of Error Message Containing Sensitive Information in microweber/microweber (critical 9.4)
- [CVE-2022-0913](https://insights.sbomify.com/CVE-2022-0913/): Integer Overflow or Wraparound in microweber/microweber (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0721 and fix it if it is affected.

What it is: CVE-2022-0721 is a high-severity vulnerability in Microweber Microweber, published on 23 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0721 in the wild and no public exploit code.

Affected packages and fixed versions:
- microweber/microweber (Packagist): affected all versions; fixed in 1.3
- microweber/microweber (Packagist): affected all versions; fixed in 1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0721/ (Markdown: https://insights.sbomify.com/CVE-2022-0721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0721
- OSV: https://osv.dev/vulnerability/CVE-2022-0721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0721/
Summaries are generated and may contain mistakes; the official description above is the record.
