# CVE-2022-0722: Exposure of Sensitive Information to an Unauthorized Actor in ionicabizau/parse-url

> An attacker can access sensitive information through the parse-url library, requiring developers to upgrade to a secure version.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-4p35-cfcx-8653

## What is CVE-2022-0722?

CVE-2022-0722 is a medium-severity vulnerability in ionicabizau/parse-url, published on 27 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository ionicabizau/parse-url prior to 7.0.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-0722?

2 open source packages ship an affected version, including parse-url. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-url` | npm | All versions | 6.0.1 |
| `parse-url` | npm | All versions | 6.0.1 |

Products: Parse-Url Project Parse-Url.

## How do I fix CVE-2022-0722?

Upgrade parse-url to 6.0.1 or later.

## Is CVE-2022-0722 being exploited?

There is no known exploitation of CVE-2022-0722 in the wild and no public exploit code.

## Other vulnerabilities in ionicabizau/parse-url

- [CVE-2022-3224](https://insights.sbomify.com/CVE-2022-3224/): Misinterpretation of Input in ionicabizau/parse-url (critical 9.4)
- [CVE-2022-2216](https://insights.sbomify.com/CVE-2022-2216/): Server-Side Request Forgery (SSRF) in ionicabizau/parse-url (critical 9.4)
- [CVE-2022-2900](https://insights.sbomify.com/CVE-2022-2900/): Server-Side Request Forgery (SSRF) in ionicabizau/parse-url (critical 9.1)
- [CVE-2022-2217](https://insights.sbomify.com/CVE-2022-2217/): Cross-site Scripting (XSS) - Generic in ionicabizau/parse-url (critical 9.1)
- [CVE-2022-2218](https://insights.sbomify.com/CVE-2022-2218/): Cross-site Scripting (XSS) - Stored in ionicabizau/parse-url (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0722 and fix it if it is affected.

What it is: CVE-2022-0722 is a medium-severity vulnerability in ionicabizau/parse-url, published on 27 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0722 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-url (npm): affected all versions; fixed in 6.0.1
- parse-url (npm): affected all versions; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0722/ (Markdown: https://insights.sbomify.com/CVE-2022-0722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0722
- OSV: https://osv.dev/vulnerability/CVE-2022-0722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0722/
Summaries are generated and may contain mistakes; the official description above is the record.
