{"answers":{"affected":"2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0723 in the wild and no public exploit code.","fix":"Upgrade microweber/microweber to 1.2.11 or later.","what":"CVE-2022-0723 is a high-severity cross-site scripting vulnerability in Microweber Microweber, published on 26 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0723 and fix it if it is affected.\n\nWhat it is: CVE-2022-0723 is a high-severity cross-site scripting vulnerability in Microweber Microweber, published on 26 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0723 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- microweber/microweber (Packagist): affected all versions; fixed in 1.2.11\n- microweber/microweber (Packagist): affected all versions; fixed in 1.2.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0723/ (Markdown: https://insights.sbomify.com/CVE-2022-0723/index.md)","id":"CVE-2022-0723","markdown":"https://insights.sbomify.com/CVE-2022-0723/index.md","name":"CVE-2022-0723","record":{"aliases":["GHSA-4p92-fv6v-fhfj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Microweber CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in user browsers via reflected XSS in Microweber, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"microweber","vendor":"microweber"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.11.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Reflected in microweber/microweber","id":"CVE-2022-0723","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"microweber:microweber","products":["microweber:microweber"],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Insecure Storage of Sensitive Information in microweber/microweber","id":"CVE-2022-0724"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"microweber/microweber","purl":null,"source":"GHSA-4p92-fv6v-fhfj"},{"ecosystem":"Packagist","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"microweber/microweber","purl":"pkg:composer/microweber/microweber","source":"GHSA-4p92-fv6v-fhfj"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in ionicabizau/parse-url","id":"CVE-2022-0722"},"products":["microweber/microweber"],"published":"2022-02-26","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in microweber/microweber","id":"CVE-2022-0558","kev_date_added":null,"published":"2022-02-10"},{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2020-23138","kev_date_added":null,"published":"2020-11-09"},{"cvss_score":9.4,"headline":"Business Logic Errors in microweber/microweber","id":"CVE-2022-0688","kev_date_added":null,"published":"2022-02-20"},{"cvss_score":9.4,"headline":"Generation of Error Message Containing Sensitive Information in microweber/microweber","id":"CVE-2022-0660","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":9.1,"headline":"Integer Overflow or Wraparound in microweber/microweber","id":"CVE-2022-0913","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":9.1,"headline":"Insecure Storage of Sensitive Information in microweber/microweber","id":"CVE-2022-0724","kev_date_added":null,"published":"2022-02-23"},{"cvss_score":8.8,"headline":"Microweber file upload vulnerability","id":"CVE-2023-49052","kev_date_added":null,"published":"2023-11-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["microweber"]},"summary":"Attackers can execute arbitrary scripts in user browsers via reflected XSS in Microweber, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2022-0723/"}