CVE-2022-0738 Information disclosure in GitLab
GitLab leaks user passwords when adding mirrors with SSH credentials under specific conditions, exposing sensitive authentication data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-0738?
CVE-2022-0738 is a medium-severity vulnerability in Gitlab Gitlab, published on 28 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab affecting all versions starting from 14.6 before 14.6.5, all versions starting from 14.7 before 14.7.4, all versions starting from 14.8 before 14.8.2. GitLab was leaking user passwords when adding mirrors with SSH credentials under specific conditions.
Weakness: CWE-522
Which versions are affected by CVE-2022-0738?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.6.0 | 14.6.5, 14.7.4, 14.8.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-0738?
Upgrade gitlab to a fixed version for your release line: 14.6.5, 14.7.4 or 14.8.2.
Is CVE-2022-0738 being exploited?
There is no known exploitation of CVE-2022-0738 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-0738, GHSA-3g66-9x43-7v6m, UBUNTU-CVE-2022-0738.