CVE-2022-0740 Missing authorization in GitLab

Low 3.1 Published Updated

Attackers can close Asana tasks from unrestricted branches due to incorrect authorization in the GitLab Asana integration.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0740?

CVE-2022-0740 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Incorrect authorization in the Asana integration's branch restriction feature in all versions of GitLab CE/EE starting from version 7.8.0 before 14.7.7, all versions starting from 14.8 before 14.8.5, all versions starting from 14.9 before 14.9.2 makes it possible to close Asana tasks from unrestricted branches.

Weakness: CWE-863

Which versions are affected by CVE-2022-0740?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.8.014.7.7, 14.8.5, 14.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-0740?

Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-0740 being exploited?

There is no known exploitation of CVE-2022-0740 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-0740, GHSA-rq9r-r987-7r36, UBUNTU-CVE-2022-0740.

Is CVE-2022-0740 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free