# CVE-2022-0758: Rapid7 Nexpose Reflected XSS

> An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the shared scan configuration component of Rapid7 Nexpose.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Mar 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-q56j-r2q6-8m2c

## What is CVE-2022-0758?

CVE-2022-0758 is a low-severity cross-site scripting vulnerability in Rapid7 Nexpose, published on 17 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool. With this vulnerability an attacker could pass literal values as the test credentials, providing the opportunity for a potential XSS attack. This issue is fixed in Rapid7 Nexpose version 6.6.130.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0758?

It affects 1 product.


Products: Rapid7 Nexpose.

## How do I fix CVE-2022-0758?

No fix has been published for CVE-2022-0758 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-0758 being exploited?

There is no known exploitation of CVE-2022-0758 in the wild and no public exploit code.

## Other vulnerabilities in Rapid7 Nexpose

- [CVE-2017-5264](https://insights.sbomify.com/CVE-2017-5264/): Cross-site request forgery in Nexpose (high 8.8)
- [CVE-2019-5638](https://insights.sbomify.com/CVE-2019-5638/): Rapid7 Nexpose Insufficient Session Management (high 8.7)
- [CVE-2017-5243](https://insights.sbomify.com/CVE-2017-5243/): Weak cryptography in Nexpose hardware appliance (high 8.5)
- [CVE-2017-5232](https://insights.sbomify.com/CVE-2017-5232/): Other in Nexpose (high 7.8)
- [CVE-2017-5230](https://insights.sbomify.com/CVE-2017-5230/): Hardcoded credentials in Nexpose (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0758 and fix it if it is affected.

What it is: CVE-2022-0758 is a low-severity cross-site scripting vulnerability in Rapid7 Nexpose, published on 17 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0758 in the wild and no public exploit code.

Affected product: Rapid7 Nexpose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0758/ (Markdown: https://insights.sbomify.com/CVE-2022-0758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0758
- OSV: https://osv.dev/vulnerability/CVE-2022-0758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0758/
Summaries are generated and may contain mistakes; the official description above is the record.
