{"answers":{"affected":"2 open source packages ship an affected version, including kubeclient. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0759 in the wild and no public exploit code.","fix":"Upgrade kubeclient to 4.9.3 or later.","what":"CVE-2022-0759 is a high-severity vulnerability in kubeclient, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0759 and fix it if it is affected.\n\nWhat it is: CVE-2022-0759 is a high-severity vulnerability in kubeclient, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0759 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kubeclient (RubyGems): affected all versions; fixed in 4.9.3\n- kubeclient (RubyGems): affected all versions; fixed in 4.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0759/ (Markdown: https://insights.sbomify.com/CVE-2022-0759/index.md)","id":"CVE-2022-0759","markdown":"https://insights.sbomify.com/CVE-2022-0759/index.md","name":"CVE-2022-0759","record":{"aliases":["DEBIAN-CVE-2022-0759","GHSA-69p3-xp37-f692","UBUNTU-CVE-2022-0759"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby Kubernetes client","requires_auth":"none","summary":"Ruby applications using kubeclient are vulnerable to Man-in-the-Middle attacks when parsing kubeconfig files without custom CA settings.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"kubeclient","vendor":"redhat"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"A flaw was found in all versions of kubeclient up to (but not including) v4.9.3, the Ruby client for Kubernetes REST API, in the way it parsed kubeconfig files. When the kubeconfig file does not configure custom CA to verify certs, kubeclient ends up accepting any certificate (it wrongly returns VERIFY_NONE). Ruby applications that leverage kubeclient to parse kubeconfig files are susceptible to Man-in-the-middle attacks (MITM).","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in kubeclient","id":"CVE-2022-0759","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"weak_cryptography","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Simple Link Directory \u003c 7.7.2 - Unauthenticated SQL injection","id":"CVE-2022-0760"},"packages":[{"ecosystem":"RubyGems","fixed":["4.9.3"],"introduced":["0"],"last_affected":[],"package":"kubeclient","purl":null,"source":"GHSA-69p3-xp37-f692"},{"ecosystem":"RubyGems","fixed":["4.9.3"],"introduced":["0"],"last_affected":[],"package":"kubeclient","purl":"pkg:gem/kubeclient","source":"GHSA-69p3-xp37-f692"}],"prev":{"headline":"Rapid7 Nexpose Reflected XSS","id":"CVE-2022-0758"},"products":["kubeclient"],"published":"2022-03-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Ruby applications using kubeclient are vulnerable to Man-in-the-Middle attacks when parsing kubeconfig files without custom CA settings.","url":"https://insights.sbomify.com/CVE-2022-0759/"}