{"answers":{"affected":"2 open source packages ship an affected version, including strapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0764 in the wild and no public exploit code.","fix":"Upgrade strapi to 4.1.0 or later.","what":"CVE-2022-0764 is a medium-severity command injection vulnerability in strapi/strapi, published on 26 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0764 and fix it if it is affected.\n\nWhat it is: CVE-2022-0764 is a medium-severity command injection vulnerability in strapi/strapi, published on 26 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0764 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- strapi (npm): affected all versions; fixed in 4.1.0\n- strapi (npm): affected all versions; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0764/ (Markdown: https://insights.sbomify.com/CVE-2022-0764/index.md)","id":"CVE-2022-0764","markdown":"https://insights.sbomify.com/CVE-2022-0764/index.md","name":"CVE-2022-0764","record":{"aliases":["GHSA-xrjf-phvv-r4vr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Strapi CMS","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary commands on the server hosting the Strapi CMS, leading to full system compromise.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"strapi","vendor":"strapi"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:L","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Arbitrary Command Injection in GitHub repository strapi/strapi prior to 4.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Command Injection in strapi/strapi","id":"CVE-2022-0764","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Loco Translate \u003c 2.6.1 - Authenticated Stored Cross-Site Scripting","id":"CVE-2022-0765"},"packages":[{"ecosystem":"npm","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"strapi","purl":null,"source":"GHSA-xrjf-phvv-r4vr"},{"ecosystem":"npm","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"strapi","purl":"pkg:npm/strapi","source":"GHSA-xrjf-phvv-r4vr"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in microweber/microweber","id":"CVE-2022-0763"},"products":["strapi/strapi"],"published":"2022-02-26","related":[{"cvss_score":7.2,"headline":"Strapi Cleartext Storage of Sensitive Information","id":"CVE-2023-22894","kev_date_added":"2026-10-08","published":"2023-04-19"},{"cvss_score":10,"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621","kev_date_added":null,"published":"2023-04-19"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Strapi","id":"CVE-2022-27263","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Authorization bypass in Strapi","id":"CVE-2020-27664","kev_date_added":null,"published":"2020-10-22"},{"cvss_score":9.8,"headline":"Strapi allows unauthenticated attacker to reset admin password without valid reset token","id":"CVE-2019-18818","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":9.3,"headline":"Strapi Vulnerable to SQL Injection in Content Type Builder","id":"CVE-2026-22599","kev_date_added":null,"published":"2026-05-14"},{"cvss_score":9.2,"headline":"Strapi may leak sensitive data via relational filtering due to lack of query sanitization","id":"CVE-2026-27886","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["strapi"]},"summary":"Attackers can execute arbitrary commands on the server hosting the Strapi CMS, leading to full system compromise.","url":"https://insights.sbomify.com/CVE-2022-0764/"}