# CVE-2022-0776: Cross-site Scripting (XSS) - DOM in hakimel/reveal.js

> An attacker can execute arbitrary JavaScript in the victim's browser via DOM-based XSS in the reveal.js presentation library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hhqj-cfjx-vj25

## What is CVE-2022-0776?

CVE-2022-0776 is a medium-severity cross-site scripting vulnerability in hakimel/reveal.js, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - DOM in GitHub repository hakimel/reveal.js prior to 4.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0776?

2 open source packages ship an affected version, including reveal.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reveal.js` | npm | All versions | 4.3.0 |
| `reveal.js` | npm | All versions | 4.3.0 |

Products: Revealjs Reveal.js.

## How do I fix CVE-2022-0776?

Upgrade reveal.js to 4.3.0 or later.

## Is CVE-2022-0776 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0776 exists.

Public exploit code:

- RevealJS postMessage <4.3.0 - Cross-Site Scripting (nuclei): http/cves/2022/CVE-2022-0776.yaml

## Other vulnerabilities in hakimel/reveal.js

- [CVE-2020-8127](https://insights.sbomify.com/CVE-2020-8127/): Cross-site Scripting in reveal.js (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0776 and fix it if it is affected.

What it is: CVE-2022-0776 is a medium-severity cross-site scripting vulnerability in hakimel/reveal.js, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0776 exists.

Affected packages and fixed versions:
- reveal.js (npm): affected all versions; fixed in 4.3.0
- reveal.js (npm): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0776/ (Markdown: https://insights.sbomify.com/CVE-2022-0776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0776
- OSV: https://osv.dev/vulnerability/CVE-2022-0776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0776/
Summaries are generated and may contain mistakes; the official description above is the record.
