# CVE-2022-0839: Improper Restriction of XML External Entity Reference in liquibase/liquibase

> An attacker can exploit XML External Entity vulnerabilities in Liquibase to read sensitive files or cause denial of service.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2022
- **Updated:** 3 Nov 2025
- **Also known as:** GHSA-jvfv-hrrc-6q72

## What is CVE-2022-0839?

CVE-2022-0839 is a high-severity vulnerability in liquibase/liquibase, published on 4 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Restriction of XML External Entity Reference in GitHub repository liquibase/liquibase prior to 4.8.0.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-0839?

2 open source packages ship an affected version, including org.liquibase:liquibase-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.liquibase:liquibase-core` | Maven | All versions | 4.8.0 |
| `org.liquibase:liquibase-core` | Maven | All versions | 4.8.0 |

Products: Liquibase Liquibase, Oracle Sqlcl.

## How do I fix CVE-2022-0839?

Upgrade org.liquibase:liquibase-core to 4.8.0 or later.

## Is CVE-2022-0839 being exploited?

There is no known exploitation of CVE-2022-0839 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0839 and fix it if it is affected.

What it is: CVE-2022-0839 is a high-severity vulnerability in liquibase/liquibase, published on 4 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0839 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.liquibase:liquibase-core (Maven): affected all versions; fixed in 4.8.0
- org.liquibase:liquibase-core (Maven): affected all versions; fixed in 4.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0839/ (Markdown: https://insights.sbomify.com/CVE-2022-0839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0839
- OSV: https://osv.dev/vulnerability/CVE-2022-0839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0839/
Summaries are generated and may contain mistakes; the official description above is the record.
