# CVE-2022-0845: Code Injection in pytorchlightning/pytorch-lightning

> Attackers can execute arbitrary code via injection in PyTorch Lightning, requiring an upgrade to the latest version.

- **Severity:** High 7.3 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-r5qj-cvf9-p85h, PYSEC-2022-181, PYSEC-2026-3969

## What is CVE-2022-0845?

CVE-2022-0845 is a high-severity code injection vulnerability in pytorchlightning/pytorch-lightning, published on 5 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-0845?

4 open source packages ship an affected version, including pytorch-lightning and lightning. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch-lightning` | PyPI | All versions | 1.6.0 |
| `pytorch-lightning` | PyPI | All versions | 1.6.0 |
| `pytorch-lightning` | PyPI | All versions | 1.6.0 |
| `lightning` | PyPI | All versions | 1.6.0 |

Products: Lightningai Pytorch Lightning.

## How do I fix CVE-2022-0845?

Upgrade pytorch-lightning to 1.6.0 or later.

## Is CVE-2022-0845 being exploited?

There is no known exploitation of CVE-2022-0845 in the wild and no public exploit code.

## Other vulnerabilities in pytorchlightning/pytorch-lightning

- [CVE-2024-5452](https://insights.sbomify.com/CVE-2024-5452/): RCE via Property/Class Pollution in lightning-ai/pytorch-lightning (critical 9.8)
- [CVE-2026-44484](https://insights.sbomify.com/CVE-2026-44484/): Compromise of PyTorch Lightning PyPi Package Versions (critical 9.3)
- [CVE-2024-8019](https://insights.sbomify.com/CVE-2024-8019/): Arbitrary File Write/Overwrite in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2024-5980](https://insights.sbomify.com/CVE-2024-5980/): Arbitrary File Write via /v1/runs API endpoint in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2026-31221](https://insights.sbomify.com/CVE-2026-31221/): PyTorch Lightning load_from_checkpoint has an insecure checkpoint deserialization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0845 and fix it if it is affected.

What it is: CVE-2022-0845 is a high-severity code injection vulnerability in pytorchlightning/pytorch-lightning, published on 5 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0845 in the wild and no public exploit code.

Affected packages and fixed versions:
- pytorch-lightning (PyPI): affected all versions; fixed in 1.6.0
- pytorch-lightning (PyPI): affected all versions; fixed in 1.6.0
- pytorch-lightning (PyPI): affected all versions; fixed in 1.6.0
- lightning (PyPI): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0845/ (Markdown: https://insights.sbomify.com/CVE-2022-0845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0845
- OSV: https://osv.dev/vulnerability/CVE-2022-0845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0845/
Summaries are generated and may contain mistakes; the official description above is the record.
