{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-0860 in the wild and no public exploit code.","fix":"Upgrade cobbler to 3.3.2 or later.","what":"CVE-2022-0860 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0860 and fix it if it is affected.\n\nWhat it is: CVE-2022-0860 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0860 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 3.3.2\n- cobbler (PyPI): affected all versions; fixed in 3.3.2\n- cobbler (PyPI): affected all versions; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0860/ (Markdown: https://insights.sbomify.com/CVE-2022-0860/index.md)","id":"CVE-2022-0860","markdown":"https://insights.sbomify.com/CVE-2022-0860/index.md","name":"CVE-2022-0860","record":{"aliases":["GHSA-mcg6-h362-cmq5","PYSEC-2022-177","UBUNTU-CVE-2022-0860","openSUSE-SU-2024:11904-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"An attacker can bypass authorization checks in Cobbler, potentially accessing restricted functionality without proper credentials.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"cobbler","vendor":"cobbler_project"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"Improper Authorization in GitHub repository cobbler/cobbler prior to 3.3.2.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"missing_authorization","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"ePO XML extended entity vulnerability","id":"CVE-2022-0861"},"packages":[{"ecosystem":"PyPI","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-mcg6-h362-cmq5"},{"ecosystem":"PyPI","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-mcg6-h362-cmq5"},{"ecosystem":"PyPI","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2022-177"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.3.2.0+git.9044aa99-1.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/opensuse/cobbler\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11904-1"}],"prev":{"headline":"ePO database restoration vulnerability","id":"CVE-2022-0859"},"products":["cobbler/cobbler"],"published":"2022-03-11","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","kev_date_added":null,"published":"2018-08-09"},{"cvss_score":9.8,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":7.8,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["cobbler"]},"summary":"An attacker can bypass authorization checks in Cobbler, potentially accessing restricted functionality without proper credentials.","url":"https://insights.sbomify.com/CVE-2022-0860/"}