# CVE-2022-0866: Race condition in Wildfly

> A race condition in WildFly/JBoss EJB RunAs handling allows attackers to bypass security checks and impersonate other users in concurrent environments.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-wildfly-2022-0866, GHSA-pjxg-p9c7-7c3v

## What is CVE-2022-0866?

CVE-2022-0866 is a medium-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 10 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This is a concurrency issue that can result in the wrong caller principal being returned from the session context of an EJB that is configured with a RunAs principal. In particular, the org.jboss.as.ejb3.component.EJBComponent class has an incomingRunAsIdentity field. This field is used by the org.jboss.as.ejb3.security.RunAsPrincipalInterceptor to keep track of the current identity prior to switching to a new identity created using the RunAs principal. The exploit consist that the EJBComponent#incomingRunAsIdentity field is currently just a SecurityIdentity. This means in a concurrent environment, where multiple users are repeatedly invoking an EJB that is configured with a RunAs principal, it's possible for the wrong the caller principal to be returned from EJBComponent#getCallerPrincipal. Similarly, it's also possible for EJBComponent#isCallerInRole to return the wrong value. Both of these methods rely on incomingRunAsIdentity. Affects all versions of JBoss EAP from 7.1.0 and all versions of WildFly 11+ when Elytron is enabled.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-0866?

1 open source package ship an affected version, including wildfly. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wildfly` | Bitnami | From 11.0.0 | 26.1.1 |

Products: Redhat Jboss Enterprise Application Platform, Redhat Openstack Platform, Redhat Wildfly.

## How do I fix CVE-2022-0866?

Upgrade wildfly to 26.1.1 or later.

## Is CVE-2022-0866 being exploited?

There is no known exploitation of CVE-2022-0866 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2017-12149](https://insights.sbomify.com/CVE-2017-12149/): Red Hat JBoss Application Server Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2010-1428](https://insights.sbomify.com/CVE-2010-1428/): Red Hat JBoss Information Disclosure (medium 5.9, exploited in the wild)
- [CVE-2010-0738](https://insights.sbomify.com/CVE-2010-0738/): Red Hat JBoss Authentication Bypass (low 3.7, exploited in the wild)
- [CVE-2016-3690](https://insights.sbomify.com/CVE-2016-3690/): Deserialization in n/a (critical 9.8)
- [CVE-2017-7504](https://insights.sbomify.com/CVE-2017-7504/): Deserialization in JBoss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0866 and fix it if it is affected.

What it is: CVE-2022-0866 is a medium-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 10 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0866 in the wild and no public exploit code.

Affected packages and fixed versions:
- wildfly (Bitnami): affected from 11.0.0; fixed in 26.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0866/ (Markdown: https://insights.sbomify.com/CVE-2022-0866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0866
- OSV: https://osv.dev/vulnerability/CVE-2022-0866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0866/
Summaries are generated and may contain mistakes; the official description above is the record.
