# CVE-2022-0868: Open Redirect in medialize/uri.js

> An attacker can redirect users to malicious sites via the uri.js library, potentially facilitating phishing attacks.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8h2f-7jc4-7m3m

## What is CVE-2022-0868?

CVE-2022-0868 is a high-severity vulnerability in medialize/uri.js, published on 6 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Open Redirect in GitHub repository medialize/uri.js prior to 1.19.10.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-0868?

2 open source packages ship an affected version, including urijs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urijs` | npm | All versions | 1.19.10 |
| `urijs` | npm | All versions | 1.19.10 |

Products: Uri.js Project Uri.js.

## How do I fix CVE-2022-0868?

Upgrade urijs to 1.19.10 or later.

## Is CVE-2022-0868 being exploited?

There is no known exploitation of CVE-2022-0868 in the wild and no public exploit code.

## Other vulnerabilities in medialize/uri.js

- [CVE-2021-27516](https://insights.sbomify.com/CVE-2021-27516/): URIjs Hostname spoofing via backslashes in URL (high 7.5)
- [CVE-2022-1243](https://insights.sbomify.com/CVE-2022-1243/): CRHTLF can lead to invalid protocol extraction potentially leading to XSS in medialize/uri.js (high 7.2)
- [CVE-2022-1233](https://insights.sbomify.com/CVE-2022-1233/): URL Confusion When Scheme Not Supplied in medialize/uri.js (medium 6.5)
- [CVE-2020-26291](https://insights.sbomify.com/CVE-2020-26291/): Hostname spoofing in URI.js (medium 6.5)
- [CVE-2022-24723](https://insights.sbomify.com/CVE-2022-24723/): Improper Input Validation in URI.js (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0868 and fix it if it is affected.

What it is: CVE-2022-0868 is a high-severity vulnerability in medialize/uri.js, published on 6 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0868 in the wild and no public exploit code.

Affected packages and fixed versions:
- urijs (npm): affected all versions; fixed in 1.19.10
- urijs (npm): affected all versions; fixed in 1.19.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0868/ (Markdown: https://insights.sbomify.com/CVE-2022-0868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0868
- OSV: https://osv.dev/vulnerability/CVE-2022-0868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0868/
Summaries are generated and may contain mistakes; the official description above is the record.
