# CVE-2022-0871: Missing Authorization in gogs/gogs

> Attackers can access or modify repository data without proper authorization checks in the Gogs Git hosting service.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** CLEANSTART-2024-BZ87721, GHSA-gw5h-h6hj-f56g, GO-2022-0369

## What is CVE-2022-0871?

CVE-2022-0871 is a high-severity missing authorization vulnerability in gogs/gogs, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing Authorization in GitHub repository gogs/gogs prior to 0.12.5.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-0871?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | 0.12.5 |
| `gogs.io/gogs` | Go | All versions | 0.12.5 |
| `gogs.io/gogs` | Go | All versions | 0.12.5 |

Products: Gogs Gogs.

## How do I fix CVE-2022-0871?

Upgrade gogs.io/gogs to 0.12.5 or later.

## Is CVE-2022-0871 being exploited?

There is no known exploitation of CVE-2022-0871 in the wild and no public exploit code.

## Other vulnerabilities in gogs/gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0871 and fix it if it is affected.

What it is: CVE-2022-0871 is a high-severity missing authorization vulnerability in gogs/gogs, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0871 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.5
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.5
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0871/ (Markdown: https://insights.sbomify.com/CVE-2022-0871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0871
- OSV: https://osv.dev/vulnerability/CVE-2022-0871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0871/
Summaries are generated and may contain mistakes; the official description above is the record.
