CVE-2022-0903 Stack overflow in SAML login in Mattermost
An attacker can crash the Mattermost server by submitting a maliciously crafted POST body to the SAML login feature.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-0903?
CVE-2022-0903 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 9 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A call stack overflow bug in the SAML login feature in Mattermost server in versions up to and including 6.3.2 allows an attacker to crash the server via submitting a maliciously crafted POST body.
Weakness: CWE-787
Which versions are affected by CVE-2022-0903?
1 open source package ship an affected version, including mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mattermost Bitnami | All versions | 5.37.8, 6.1.3, 6.2.3, 6.3.3 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2022-0903?
Upgrade mattermost to a fixed version for your release line: 5.37.8, 6.1.3, 6.2.3 or 6.3.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-0903 being exploited?
There is no known exploitation of CVE-2022-0903 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2022-0903, GHSA-8wqp-c6pq-684g.