CVE-2022-0904 Stack overflow in document extractor in Mattermost
An attacker can crash the Mattermost server by submitting a maliciously crafted Apple Pages document due to a stack overflow in the document extractor.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-0904?
CVE-2022-0904 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A stack overflow bug in the document extractor in Mattermost Server in versions up to and including 6.3.2 allows an attacker to crash the server via submitting a maliciously crafted Apple Pages document.
Weakness: CWE-787
Which versions are affected by CVE-2022-0904?
1 open source package ship an affected version, including mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mattermost Bitnami | From 5.0.0 | 5.37.8, 6.1.3, 6.2.3, 6.3.3 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2022-0904?
Upgrade mattermost to a fixed version for your release line: 5.37.8, 6.1.3, 6.2.3 or 6.3.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-0904 being exploited?
There is no known exploitation of CVE-2022-0904 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2022-0904, GHSA-c96x-c679-gx9j.