{"answers":{"affected":"3 open source packages ship an affected version, including pimcore/data-hub and pimcore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0955 in the wild and no public exploit code.","fix":"Upgrade pimcore/data-hub to 1.2.4 or later.","what":"CVE-2022-0955 is a medium-severity cross-site scripting vulnerability in pimcore/data-hub, published on 24 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0955 and fix it if it is affected.\n\nWhat it is: CVE-2022-0955 is a medium-severity cross-site scripting vulnerability in pimcore/data-hub, published on 24 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0955 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/data-hub (Packagist): affected all versions; fixed in 1.2.4\n- pimcore/data-hub (Packagist): affected all versions; fixed in 1.2.4\n- pimcore (Bitnami): affected all versions; fixed in 1.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0955/ (Markdown: https://insights.sbomify.com/CVE-2022-0955/index.md)","id":"CVE-2022-0955","markdown":"https://insights.sbomify.com/CVE-2022-0955/index.md","name":"CVE-2022-0955","record":{"aliases":["BIT-pimcore-2022-0955","GHSA-vc5r-xfc4-4x22"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Pimcore Data Hub","requires_auth":"high_privilege","summary":"Stored Cross-Site Scripting in Pimcore Data Hub allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"data-hub","vendor":"pimcore"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/data-hub prior to 1.2.4.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in pimcore/data-hub","id":"CVE-2022-0955","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Stored XSS via File Upload in star7th/showdoc","id":"CVE-2022-0956"},"packages":[{"ecosystem":"Bitnami","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"pimcore","purl":"pkg:bitnami/pimcore","source":"BIT-pimcore-2022-0955"},{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"pimcore/data-hub","purl":null,"source":"GHSA-vc5r-xfc4-4x22"},{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"pimcore/data-hub","purl":"pkg:composer/pimcore/data-hub","source":"GHSA-vc5r-xfc4-4x22"}],"prev":{"headline":"Stored Cross-site Scripting in Microweber","id":"CVE-2022-0954"},"products":["pimcore/data-hub"],"published":"2022-03-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["pimcore"]},"summary":"Stored Cross-Site Scripting in Pimcore Data Hub allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2022-0955/"}