{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0959 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 6.7 or later.","what":"CVE-2022-0959 is a medium-severity path traversal vulnerability in pgadmin, published on 16 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0959 and fix it if it is affected.\n\nWhat it is: CVE-2022-0959 is a medium-severity path traversal vulnerability in pgadmin, published on 16 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0959 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 6.7\n- pgadmin4 (PyPI): affected all versions; fixed in 6.7\n- pgadmin4 (PyPI): affected all versions; fixed in 6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0959/ (Markdown: https://insights.sbomify.com/CVE-2022-0959/index.md)","id":"CVE-2022-0959","markdown":"https://insights.sbomify.com/CVE-2022-0959/index.md","name":"CVE-2022-0959","record":{"aliases":["GHSA-cr8c-972v-rmp3","MGASA-2022-0257","PYSEC-2026-729","SUSE-SU-2022:1541-1"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"pgAdmin web application","requires_auth":"low_privilege","summary":"Authenticated users can exploit path traversal to upload files to arbitrary locations, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"A malicious, but authorised and authenticated user can construct an HTTP request using their existing CSRF token and session cookie to manually upload files to any location that the operating system user account under which pgAdmin is running has permission to write.","ecosystems":["PyPI","SUSE:Linux Enterprise Module for Server Applications 15 SP3","openSUSE:Leap 15.3","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pgAdmin 4 Path Traversal vulnerability","id":"CVE-2022-0959","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"Stored XSS viva .properties file upload in star7th/showdoc","id":"CVE-2022-0960"},"packages":[{"ecosystem":"PyPI","fixed":["6.7"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-cr8c-972v-rmp3"},{"ecosystem":"PyPI","fixed":["6.7"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-cr8c-972v-rmp3"},{"ecosystem":"PyPI","fixed":["6.7"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-729"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP3","fixed":["4.30-150300.3.3.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/suse/pgadmin4\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP3","source":"SUSE-SU-2022:1541-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["4.30-150300.3.3.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/opensuse/pgadmin4\u0026distro=openSUSE%20Leap%2015.3","source":"SUSE-SU-2022:1541-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["4.30-150300.3.3.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/opensuse/pgadmin4\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2022:1541-1"}],"prev":{"headline":"Mark Posts \u003c 2.0.1 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-0958"},"products":["pgadmin"],"published":"2022-03-16","related":[{"cvss_score":9.9,"headline":"pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment","id":"CVE-2025-2945","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":9.9,"headline":"OAuth2 client id and secret exposed through the web browser in pgAdmin 4","id":"CVE-2024-9014","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.5,"headline":"Deserialization in pgAdmin 4","id":"CVE-2026-12046","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"SQL injection in pgAdmin 4","id":"CVE-2026-17351","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"Command injection in pgAdmin 4","id":"CVE-2026-17566","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"pgAdmin 4: AI Assistant read-only transaction bypass allows unauthorised writes and remote code execution","id":"CVE-2026-12045","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode","id":"CVE-2026-7813","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Authenticated users can exploit path traversal to upload files to arbitrary locations, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2022-0959/"}