# CVE-2022-0959: pgAdmin 4 Path Traversal vulnerability

> Authenticated users can exploit path traversal to upload files to arbitrary locations, potentially leading to code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cr8c-972v-rmp3, MGASA-2022-0257, PYSEC-2026-729, SUSE-SU-2022:1541-1

## What is CVE-2022-0959?

CVE-2022-0959 is a medium-severity path traversal vulnerability in pgadmin, published on 16 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A malicious, but authorised and authenticated user can construct an HTTP request using their existing CSRF token and session cookie to manually upload files to any location that the operating system user account under which pgAdmin is running has permission to write.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-0959?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 6.7 |
| `pgadmin4` | PyPI | All versions | 6.7 |
| `pgadmin4` | PyPI | All versions | 6.7 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 4.30-150300.3.3.1 |
| `pgadmin4` | openSUSE:Leap 15.3 | All versions | 4.30-150300.3.3.1 |
| `pgadmin4` | openSUSE:Leap 15.4 | All versions | 4.30-150300.3.3.1 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2022-0959?

Upgrade pgadmin4 to 6.7 or later.

## Is CVE-2022-0959 being exploited?

There is no known exploitation of CVE-2022-0959 in the wild and no public exploit code.

## Other vulnerabilities in pgadmin

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0959 and fix it if it is affected.

What it is: CVE-2022-0959 is a medium-severity path traversal vulnerability in pgadmin, published on 16 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0959 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 6.7
- pgadmin4 (PyPI): affected all versions; fixed in 6.7
- pgadmin4 (PyPI): affected all versions; fixed in 6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0959/ (Markdown: https://insights.sbomify.com/CVE-2022-0959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0959
- OSV: https://osv.dev/vulnerability/CVE-2022-0959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0959/
Summaries are generated and may contain mistakes; the official description above is the record.
