# CVE-2022-0991: Insufficient Session Expiration in admidio/admidio

> Attackers can hijack user sessions due to insufficient expiration, potentially taking over accounts in Admidio.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-mf79-f657-47ww

## What is CVE-2022-0991?

CVE-2022-0991 is a high-severity vulnerability in admidio/admidio, published on 19 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Insufficient Session Expiration in GitHub repository admidio/admidio prior to 4.1.9.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-0991?

2 open source packages ship an affected version, including admidio/admidio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 4.1.9 |
| `admidio/admidio` | Packagist | All versions | 4.1.9 |

Products: Admidio Admidio.

## How do I fix CVE-2022-0991?

Upgrade admidio/admidio to 4.1.9 or later.

## Is CVE-2022-0991 being exploited?

There is no known exploitation of CVE-2022-0991 in the wild and no public exploit code.

## Other vulnerabilities in admidio/admidio

- [CVE-2024-37906](https://insights.sbomify.com/CVE-2024-37906/): Admidio has Blind SQL Injection in ecard_send.php (critical 10.0)
- [CVE-2021-32630](https://insights.sbomify.com/CVE-2021-32630/): Various (critical 9.6)
- [CVE-2026-32817](https://insights.sbomify.com/CVE-2026-32817/): Admidio is Missing Authorization and CSRF Protection on Document and Folder Deletion (critical 9.1)
- [CVE-2024-38529](https://insights.sbomify.com/CVE-2024-38529/): Admidio Vulnerable to RCE via Arbitrary File Upload in Message Attachment (critical 9.1)
- [CVE-2026-32756](https://insights.sbomify.com/CVE-2026-32756/): Admidio: Unrestricted File Upload via CSRF Token Validation Bypass in Documents & Files Module (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0991 and fix it if it is affected.

What it is: CVE-2022-0991 is a high-severity vulnerability in admidio/admidio, published on 19 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0991 in the wild and no public exploit code.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 4.1.9
- admidio/admidio (Packagist): affected all versions; fixed in 4.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0991/ (Markdown: https://insights.sbomify.com/CVE-2022-0991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0991
- OSV: https://osv.dev/vulnerability/CVE-2022-0991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0991/
Summaries are generated and may contain mistakes; the official description above is the record.
