{"answers":{"affected":"2 open source packages ship an affected version, including darylldoyle/safe-svg. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1091 in the wild and no public exploit code.","fix":"Upgrade darylldoyle/safe-svg to 1.9.10 or later.","what":"CVE-2022-1091 is a medium-severity cross-site scripting vulnerability in Unknown Safe SVG, published on 18 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-1091 and fix it if it is affected.\n\nWhat it is: CVE-2022-1091 is a medium-severity cross-site scripting vulnerability in Unknown Safe SVG, published on 18 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-1091 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- darylldoyle/safe-svg (Packagist): affected all versions; fixed in 1.9.10\n- darylldoyle/safe-svg (Packagist): affected all versions; fixed in 1.9.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1091/ (Markdown: https://insights.sbomify.com/CVE-2022-1091/index.md)","id":"CVE-2022-1091","markdown":"https://insights.sbomify.com/CVE-2022-1091/index.md","name":"CVE-2022-1091","record":{"aliases":["GHSA-5h7w-hmxc-99g5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can bypass SVG sanitization in the Safe SVG WordPress plugin by spoofing content types, leading to Cross-Site Scripting attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"safe_svg","vendor":"10up"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The sanitisation step of the Safe SVG WordPress plugin before 1.9.10 can be bypassed by spoofing the content-type in the POST request to upload a file. Exploiting this vulnerability, an attacker will be able to perform the kinds of attacks that this plugin should prevent (mainly XSS, but depending on further use of uploaded SVG files potentially other XML attacks).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Safe SVG \u003c 1.9.10 - SVG Sanitisation Bypass","id":"CVE-2022-1091","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"myCred \u003c 2.4.4 - Subscriber+ Import/Export to Email Address Disclosure","id":"CVE-2022-1092"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.10"],"introduced":["0"],"last_affected":[],"package":"darylldoyle/safe-svg","purl":null,"source":"GHSA-5h7w-hmxc-99g5"},{"ecosystem":"Packagist","fixed":["1.9.10"],"introduced":["0"],"last_affected":[],"package":"darylldoyle/safe-svg","purl":"pkg:composer/darylldoyle/safe-svg","source":"GHSA-5h7w-hmxc-99g5"}],"prev":{"headline":"Good \u0026 Bad Comments \u003c= 1.0.0 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-1090"},"products":["Safe SVG"],"published":"2022-04-18","related":[{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2019-18854","kev_date_added":null,"published":"2019-11-11"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2019-18855","kev_date_added":null,"published":"2019-11-11"},{"cvss_score":4.8,"headline":"Safe SVG \u003c 2.2.6 - Author+ SVG Sanitisation Bypass","id":"CVE-2024-8378","kev_date_added":null,"published":"2024-11-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["Unknown"]},"summary":"Attackers can bypass SVG sanitization in the Safe SVG WordPress plugin by spoofing content types, leading to Cross-Site Scripting attacks.","url":"https://insights.sbomify.com/CVE-2022-1091/"}