CVE-2022-1099 Denial of service in GitLab

Medium 4.3 Published Updated

An attacker can degrade GitLab performance by adding a large number of tags to a runner, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1099?

CVE-2022-1099 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Adding a very large number of tags to a runner in GitLab CE/EE affecting all versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allows an attacker to impact the performance of GitLab

Weakness: CWE-400

Which versions are affected by CVE-2022-1099?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions14.7.7, 14.8.5, 14.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-1099?

Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-1099 being exploited?

There is no known exploitation of CVE-2022-1099 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1099, GHSA-66xf-5qxv-jmgr, UBUNTU-CVE-2022-1099.

Is CVE-2022-1099 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free