CVE-2022-1100 Denial of service in GitLab

Medium 4.3 Published Updated

An attacker can cause high CPU usage and denial of service in GitLab by submitting specific values to the release asset link update API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1100?

CVE-2022-1100 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A potential DOS vulnerability was discovered in GitLab CE/EE affecting all versions from 13.1 prior to 14.7.7, 14.8.0 prior to 14.8.5, and 14.9.0 prior to 14.9.2. The api to update an asset as a link from a release had a regex check which caused exponential number of backtracks for certain user supplied values resulting in high CPU usage.

Weakness: CWE-772

Which versions are affected by CVE-2022-1100?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.1.014.7.7, 14.8.5, 14.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-1100?

Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-1100 being exploited?

There is no known exploitation of CVE-2022-1100 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1100, GHSA-fr4g-hmc7-w66h, UBUNTU-CVE-2022-1100.

Is CVE-2022-1100 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free