{"answers":{"affected":"It affects 5 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1116 exists.","fix":"Apply the vendor's patch.","what":"CVE-2022-1116 is a high-severity vulnerability in Linux kernel, published on 17 May 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-1116 and fix it if it is affected.\n\nWhat it is: CVE-2022-1116 is a high-severity vulnerability in Linux kernel, published on 17 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1116 exists.\n\nAffected product: Linux kernel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1116/ (Markdown: https://insights.sbomify.com/CVE-2022-1116/index.md)","id":"CVE-2022-1116","markdown":"https://insights.sbomify.com/CVE-2022-1116/index.md","name":"CVE-2022-1116","record":{"aliases":["A-234020136","GHSA-rjw7-cp46-vrpf","PUB-A-234020136","SUSE-SU-2022:3080-1","UBUNTU-CVE-2022-1116"],"analysis":{"component_type":"kernel","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux Kernel","requires_auth":"low_privilege","summary":"A local attacker can exploit an integer overflow in the Linux Kernel's io_uring to cause memory corruption and escalate privileges to root.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"linux_kernel","vendor":"linux"},{"product":"h300s_firmware","vendor":"netapp"},{"product":"h410s_firmware","vendor":"netapp"},{"product":"h500s_firmware","vendor":"netapp"},{"product":"h700s_firmware","vendor":"netapp"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer Overflow or Wraparound vulnerability in io_uring of Linux Kernel allows local attacker to cause memory corruption and escalate privileges to root. This issue affects: Linux Kernel versions prior to 5.4.189; version 5.4.24 and later versions.","ecosystems":["SUSE:Linux Enterprise Live Patching 15 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Integer overflow in Kernel","id":"CVE-2022-1116","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"linux:linux_kernel","products":["linux:linux_kernel","netapp:h300s_firmware","netapp:h410s_firmware","netapp:h500s_firmware","netapp:h700s_firmware"],"type":"integer_overflow","year":"2022"},"n_packages":1,"n_references":4,"next":{"headline":"Security feature bypass in fapolicyd","id":"CVE-2022-1117"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Live Patching 15 SP3","fixed":["2-150300.2.1"],"introduced":["0"],"last_affected":[],"package":"kernel-livepatch-SLE15-SP3_Update_23","purl":"pkg:rpm/suse/kernel-livepatch-SLE15-SP3_Update_23\u0026distro=SUSE%20Linux%20Enterprise%20Live%20Patching%2015%20SP3","source":"SUSE-SU-2022:3080-1"}],"prev":{"headline":"Memory corruption in ImageMagick","id":"CVE-2022-1115"},"products":["Kernel"],"published":"2022-05-17","related":[{"cvss_score":8.8,"headline":"Linux Kernel Out-of-Bounds Write","id":"CVE-2026-53266","kev_date_added":"2026-09-18","published":"2026-06-25"},{"cvss_score":8.8,"headline":"Linux Kernel Improper Input Validation","id":"CVE-2013-6282","kev_date_added":"2022-09-15","published":"2013-11-19"},{"cvss_score":8.4,"headline":"Linux Kernel Heap-Based Buffer Overflow","id":"CVE-2022-0185","kev_date_added":"2024-08-21","published":"2022-02-11"},{"cvss_score":8.4,"headline":"Linux Kernel Privilege Escalation","id":"CVE-2013-2094","kev_date_added":"2022-09-15","published":"2013-05-14"},{"cvss_score":7.8,"headline":"Linux Kernel Unspecified","id":"CVE-2026-53362","kev_date_added":"2026-08-27","published":"2026-07-04"},{"cvss_score":7.8,"headline":"Linux Kernel Missing Initialization of a Variable","id":"CVE-2026-46300","kev_date_added":"2026-10-28","published":"2026-05-23"},{"cvss_score":7.8,"headline":"Linux Kernel Race Condition","id":"CVE-2025-39964","kev_date_added":"2026-09-18","published":"2025-10-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["Linux"]},"summary":"A local attacker can exploit an integer overflow in the Linux Kernel's io_uring to cause memory corruption and escalate privileges to root.","url":"https://insights.sbomify.com/CVE-2022-1116/"}