CVE-2022-1120 Information disclosure in GitLab
Attackers can view sensitive information via error messages when CI/CD include directives fail in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-1120?
CVE-2022-1120 is a medium-severity vulnerability in Gitlab Gitlab, published on 4 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Missing filtering in an error message in GitLab CE/EE affecting all versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 exposed sensitive information when an include directive fails in the CI/CD configuration.
Weakness: CWE-209
Which versions are affected by CVE-2022-1120?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 14.7.7, 14.8.5, 14.9.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1120?
Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.
Is CVE-2022-1120 being exploited?
There is no known exploitation of CVE-2022-1120 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1120, GHSA-5733-m8xv-f92m, UBUNTU-CVE-2022-1120.