CVE-2022-1121 Denial of service in GitLab Pages
An attacker can cause unlimited resource consumption in GitLab Pages due to missing timeouts, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1121?
CVE-2022-1121 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A lack of appropriate timeouts in GitLab Pages included in GitLab CE/EE all versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allows an attacker to cause unlimited resource consumption.
Weakness: CWE-770
Which versions are affected by CVE-2022-1121?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 14.7.7, 14.8.5, 14.9.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1121?
Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-1121 being exploited?
There is no known exploitation of CVE-2022-1121 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1121, GHSA-4fff-jcr9-g646, UBUNTU-CVE-2022-1121.