CVE-2022-1155 Old sessions are not blocked by the login enable function. in snipe/snipe-it

High 7.4 Published Updated

Attackers can maintain access via old sessions even after login is disabled, allowing unauthorized account takeover in Snipe-IT.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1155?

CVE-2022-1155 is a high-severity authentication bypass vulnerability in Snipeitapp Snipe-It, published on 30 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Old sessions are not blocked by the login enable function. in GitHub repository snipe/snipe-it prior to 5.3.10.

Weakness: CWE-840

Which versions are affected by CVE-2022-1155?

4 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.

PackageAffectedFixed in
snipe/snipe-it PackagistAll versions5.4.2
snipe/snipe-it PackagistAll versions5.4.2
snipe/snipe-it PackagistFrom 6.0.0-RC-16.0.0-RC-6
snipe/snipe-it PackagistFrom 6.0.0-RC-16.0.0-RC-6

Products include Snipeitapp Snipe-It.

How do I fix CVE-2022-1155?

Upgrade snipe/snipe-it to a fixed version for your release line: 5.4.2 or 6.0.0-RC-6.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-1155 being exploited?

There is no known exploitation of CVE-2022-1155 in the wild and no public exploit code.

All Snipeitapp Snipe-It vulnerabilities

Sources

Also known as GHSA-636j-7x7r-gvw2.

Is CVE-2022-1155 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free