CVE-2022-1162 Hardcoded credentials in GitLab
Attackers can take over accounts registered via OmniAuth providers due to a hardcoded password in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1162?
CVE-2022-1162 is a critical vulnerability in Gitlab Gitlab, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A hardcoded password was set for accounts registered using an OmniAuth provider (e.g. OAuth, LDAP, SAML) in GitLab CE/EE versions 14.7 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allowing attackers to potentially take over accounts
Weakness: CWE-798
Which versions are affected by CVE-2022-1162?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.7.0 | 14.7.7, 14.8.5, 14.9.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1162?
Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.
Is CVE-2022-1162 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1162 exists.
Public exploit code: 1 Exploit-DB entry, 1 Nuclei template and 2 proofs of concept on GitHub.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1162, GHSA-vrqc-vwgr-qqp5, UBUNTU-CVE-2022-1162.