CVE-2022-1175 Cross-site scripting in GitLab

High 8.7 Published Updated

An attacker can inject HTML into GitLab notes to execute scripts, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1175?

CVE-2022-1175 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 4 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Improper neutralization of user input in GitLab CE/EE versions 14.4 before 14.7.7, all versions starting from 14.8 before 14.8.5, all versions starting from 14.9 before 14.9.2 allowed an attacker to exploit XSS by injecting HTML in notes.

Weakness: CWE-79

Which versions are affected by CVE-2022-1175?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.4.014.7.7, 14.8.5, 14.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-1175?

Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-1175 being exploited?

There is no known exploitation of CVE-2022-1175 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1175, GHSA-9fwv-mvpv-qrh4, UBUNTU-CVE-2022-1175.

Is CVE-2022-1175 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free